آموزش حل مشکل کار نکردن کدهای جی کوئری در وردپرس

کار نکردن کدهای جی کوئری در وردپرس حتما برای شما هم پیش اومده که وقتی اقدام به نصب افزونه خاصی در سایت خودتون می‌کنید قالب شما بعد از نصب و فعال سازی افزونه با بی نظمی مواجه شده و بخش‌های مختلف اون بهتون به درستی نشون داده نمیشه، به عنوان مثال وقتی که از افزونه‌های اسلایدر و یا ساخت افکت برای باکس‌هایی که معمولا در قالب‌های تک صفحه ای استفاده میشن با ای مشکل مواجه میشید که اسلایدر یا افکت انیمیشن شما به درستی کار نمیکنه، این مشکل بیشتر به این دلیل هست که کدهای جی کوئری مورد نیاز برای نمایش این المان‌ها به دلیل تداخلی که با سایر کدهای Jquery وردپرس دارند باعث ایجاد این مشکل میشوند.

در این آموزش ما قصد داریم تا به نحوه رفع مشکل کار نکردن کدهای جی کوئری در وردپرس بپردازیم که با استفاده از این آموزش میتونید مشکل تداخل در جی کوئری وردپرس را که میتونه بعد از نصب افزونه و یا افزودن کتابخانه‌ای از وردپرس در اون به وجود بیاد را رفع کنید. پس تا انتها با ما همراه باشید.

آموزش حل مشکل کار نکردن کدهای جی کوئری در وردپرس

مشکلی که در کار نکردن کدهای jquery وردپرس به وجود میاد در بیشتر مواقع همونطور که در بالا هم اشاره کردم به دلیل تداخل کتابخانه‌های جی کوئری هستش به این صورت که وقتی طراح قالب وردپرس شما یک کتابخانه جی کوئری را در قالب فراخوانی میکنه و شما حین استفاده از این قالب میاین و اقدام به نصب یک افزونه میکنید که از کتابخانه‌های جی‌کوئری در اون استفاده شده، چون این افزونه هم برای کارکرد خودش به کتابخانه جی کوئری نیاز داره یک بار دیگه این کتابخانه جی کوئری فراخوانی شده و همین موضوع باعث میشه تا همزمان دو کتابخانه در سایت فراخوانی شوند که باعث اختلال در عملکرد افکت ها و افزونه‌ها میشن که در نهایت بر روی کل سایت شما تاثیر خواهد گذاشت.

در حالت عادی برای استفاده از کتابخانه‌های جی کوئری طراحان میان و از کدهایی مثل نمونه زیر در قالب وردپرس استفاده می‌کنند که میتونید چنین کدهایی را در فایل‌های قالب خودتون پیدا کنید.

 

 

اما اگر تداخلی در کتابخانه‌های جی کوئری شما به وجود بیاد با بررسی سورس صفحات خودتون خواهید دید که این کدها به شکل زیر در صفحات تبدیل شدند.

درست در همینجاست که مشکل تداخل در جی کوئری وردپرس به وجود میاد و همونطور که در حالت تئوری این ماجرا مشخصه برای اینکه مشکل را برطرف کنیم کافیه تا به وردپرس بفهمونیم که این دو کتابخانه تکراری هستند و تنها باید از یکی از این کتابخانه‌ها استفاده کنه. بنابراین وارد هاست خودتون شده و روی گزینه File Manager انتخاب کنید تا به مسیر فایل منیجر در هاست خودتون وارد شوید.

 

 

سپس به مسیر /public_html/wp-content/themes/ وارد شده و سپس پوشه قالبی که روی سایت فعال هست را انتخاب کرده و وارد این پوشه شوید. در این پوشه حالا به دنبال فایلی با نام functions.php بگردید و سپس برای ویرایش فایل در هاست سی پنل روی اون راست کلیک کرده و گزینه Edit را انتخاب کنید. بعد از اینکه وارد صفحه ویرایش فایل شدید کد زیر را در مکان مناسبی از این فایل قرار بدین.

اگر مشکلتون برطرف نشد میتونید کد بالا را از فایل حذف کرده و با کد زیر جایگزین کنید تا کتابخانه جی‌کوئری پیشفرض خود وردپرس را غیرفعال کنید.

با اضافه کردن کد بالا کتابخانه‌ای که وردپرس به صورت پیشفرض از اون استفاده میکنه غیرفعال شده و از کتابخانه‌ای که در قالب و یا افزونه وجود داره استفاده خواهد شد و دیگه تداخلی در کدهای شما به وجود نخواهد آمد.

ارسال دیدگاه

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *